Foxglove - BYOS customers blocked from indexing and querying data – Incident details

BYOS customers blocked from indexing and querying data

Resolved
Partial outage 30 %
Started 17 days agoLasted about 3 hours

Affected

API

Partial outage from 5:39 PM to 8:48 PM

Updates
  • Postmortem
    Postmortem

    On May 19–20, 2026, some Foxglove customers using bring-your-own-storage (BYOS) data platforms experienced intermittent disruptions to indexing, querying, and streaming across US and EU regions. The cause was a Kubernetes configuration change that unintentionally deleted resources during a deployment, plus a downstream DNS misconfiguration after restoration. No customer data was lost. We've shipped fixes and identified follow-up work to consolidate our infrastructure-as-code ownership and improve recovery for similar issues in the future.

  • Resolved
    Resolved

    We've found and shipped a permanent fix for the underlying infrastructure misconfiguration.

  • Monitoring
    Monitoring

    The mitigation has succeeded. We are continuing to monitor and working on a permanent fix.

  • Identified
    Identified

    We've identified a mitigation and are implementing it.

  • Investigating
    Investigating
    We are currently investigating this incident.